Setup and configuration guide to configure a Cisco 877 router for ADSL connection.





Variables used in configuration:

  • DSL Username: ISP_DSL_USERNAME
  • DSL Password: ISP_DSL_PASSWORD

Setup ATM interface:

1
2
3
4
5
6
7
8
interface ATM0
 no ip address
 no ip redirects
 no ip unreachables
 no ip proxy-arp
 ip flow ingress
 no atm ilmi-keepalive
 dsl bitswap both

Setup the virtual ATM interface:

1
2
3
4
5
6
7
interface ATM0.1 point-to-point
 no ip redirects
 no ip unreachables
 no ip proxy-arp
 ip flow ingress
 pvc 8/35
  pppoe-client dial-pool-number 1

Setup the local inside interface. I will be using the default, Vlan1, interface:

1
2
3
4
5
6
7
8
9
10
interface Vlan1
 description FW_INSIDE
 ip address 172.16.1.1 255.255.255.0
 no ip redirects
 no ip unreachables
 no ip proxy-arp
 ip nat inside
 ip virtual-reassembly max-reassemblies 64
 ip tcp adjust-mss 1452
 no autostate

Setup the DSL dialer interface:

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
interface Dialer0
 description FW_OUTSIDE
 ip address negotiated
 no ip redirects
 no ip unreachables
 no ip proxy-arp
 ip mtu 1492
 ip nat outside
 ip virtual-reassembly max-reassemblies 64
 encapsulation ppp
 ip tcp adjust-mss 1452
 dialer pool 1
 dialer idle-timeout 0
 dialer persistent delay 10
 dialer-group 1
 no cdp enable
 ppp authentication pap chap callin
 ppp chap hostname ISP_DSL_USERNAME
 ppp chap password ISP_DSL_PASSWORD
 ppp pap sent-username ISP_DSL_USERNAME password ISP_DSL_PASSWORD

Create a default route for all traffic, outbound, to the Dialer0 interface:

1
ip route 0.0.0.0 0.0.0.0 Dialer0

Create an access-list to allow all traffic outbound from the inside subnet to outside any:

1
2
3
access-list 111 remark *****PERMIT local network Internet Access*****
access-list 111 permit ip 172.16.1.0 0.0.0.255 any
access-list 111 permit ip any any

Create a route-map for the inside to outside NAT and tell it to use access-list 111:

1
2
route-map NAT permit 10
 match ip address 111

Create the inside to outside NAT rule and apply it on the outside interface:

1
ip nat inside source route-map NAT interface Dialer0 overload

Display DSL connection statistics:

1
show dsl interface atm 0

Comments